El siguiente problema seguramente te sucede en varias situaciones y es cuando al querer actualizar un tema, plugin o el mismo WordPress, te sale una pantalla solicitando tus datos de conexión FTP. Esto es bastante molesto cuando se tiene un proyecto con bastantes plugins o un theme natural de WordPress que se actualice seguido, por ello vamos a ver una solución a continuación.

El proceso de actualización en WordPress requiere conectarse a tu servidor para descargar los archivos nuevos, desactivar y borrar los viejos, para a final activar los nuevos. Este proceso es necesario para temas, plugins y WordPress. ¿Se entiende?

Los puntos son los siguientes:
- Actualizar temas de WordPress
- Actualizar plugins para WordPress
- Actualizar WordPress

El aviso que te sale en pantalla es el siguiente:

Datos de conexión
Para realizar la operación que has solicitado WordPress necesita tener acceso a tu servidor web. Por favor, introduce tus datos de acceso FTP para proceder. Si no recuerdas tus datos de acceso deberías contactar con tu proveedor de alojamiento.

- Servidor
- Usuario FTP
- Contraseña FTP
- Tipo de conexión

Para evitar que cada vez que actualizas WordPress, tu tema o los plugins te salga este aviso, podemos incluir esos datos en el archivo wp-config.php y de esta manera WordPress utiliza los datos desde ahí y siempre se actualiza sin solicitar los datos FTP.

Lo que tienes que hacer es abrir tu archivo "wp-config.php" y agregar el siguiente código.

Código para evitar que WordPress solicite usuario y contraseña FTP para actualizar.

// ** AJUSTES FTP PARA ACTUALIZACIONES ** //
define('FTP_HOST', 'tudomino.com');
define('FTP_USER', 'tu-usuario');
define('FTP_PASS', 'tu-contrasea');

Primero hay que cambiar los datos por los reales de tu FTP para tudomino.com, tu-usuario y tu-contraseña, ahora coloca el código después de la linea en la que se define el idioma, que por lo general es "define ('WPLANG', 'es_ES');" y listo, ya puedes guardar los cambios en wp-config.php. Con eso cada vez que actualicemos WordPress, algún plugin o theme, todo funcionará a la primera y sin avisos.

Así evitas tener que estar buscando usuarios y contraseñas para cada cliente o proyecto, además si el un trabajo, los clientes te lo agradecerán, ya sabes, entre menos problemas o pasos, mejor.

24 Comentarios
  1. ¡Hola!.

    Tenía que decirte que, tengo el problema de que no tengo ningún servidor FTP. SIno que lo instalé en el localhost de mi PC no a ningún servidor web...

    • Peter Olle 7 años

      De forma local no necesitas nada, los permisos locales actualizan sin problemas.

      Saludos.

  2. Martin 7 años

    Simple y clara explicacion. Y problema solucionado.
    Gracias!!

    • Peter Olle 7 años

      Que bueno que te sirvió Martin.

      Saludos.

  3. jaume 6 años

    Perdonadme pero con la version 3.4.2 en localhost de Mac no funciona. Lo tendo en localhost, root y sin contraseña

    • Peter Olle 6 años

      Pues tienes algo mal en tu instalación, en tu servidor, PHP o MySql porque funciona perfectamente tanto en local, como en servidor web.

      Saludos.

  4. Cloud 6 años

    Comprueba los PHP handlers del PHP support.
    Normalmente se puede elegir entre varios., como FastCGI application, CGI application, ISAPI extension y Apache module.

    Elige FastCGI application.

    Aquí tienes una explicación de esto.http://download1.parallels.com/Plesk/PP11/11.0/Doc/en-US/online/plesk-administrator-guide/index.htm?fileName=70668.htm

    CGI y Apache escriben como root no como tu usuario ftp, así que no te permite modificar, agregar, cambiar.
    ISAPI ya no funciona en php 5.3, y posiblemente tengas 5.5.

    A mi me ha funcionado tras volverme loco

    Espero haber ayudado

    PD: Gracias por no finalizar vuestras preguntas con ¡Ah ya encontré la solución, gracias!. Si no, NADIE SE ENTERA de cómo solucionarlo. Los moderadores podrían tener esto en cuenta para ELIMINAR el post o el usuario 🙂

  5. Marcos 6 años

    Tengo instalado en Ubuntu 10.04 a PHP, mySql, Apache2, lo q quiero saber es si tengo q instalar tambien algo de FTP, pero tengo entendido q Linux trae uno propio..o no?

    • Peter Olle 6 años

      ¿Y WordPress te pide los datos?

  6. Marcos 6 años

    Si, asi es...

  7. Altoks 6 años

    Simple...Sencillo...Y además funciona perfectamente bien. Muchas Gracias!!

  8. alberto 6 años

    De alguna manera puedo saber quien de mis usuarios en wordpress actualizo la ultima version de wordpress, tengo 5 usuarios super admin y recien salio actualizacion y pedi que no actualizaron por un bug que esta en la nueva version, pero alguien la instalo y ahora dicen que nadie fue.. puedo saberlo como dueño del portal ??

    • Peter Olle 6 años

      Eso no tiene nada que ver con el tema.... Mira los logs de tu servidor, ahi puedes verlo.

      Saludos.

  9. Maricela M 5 años

    Buenas tardes, tengo un problema, yo trabajo con una herramienta de automatización, y ahora necesito un mecanismo, una herramienta, evento del sistema nose algo que me permita saber que subieron un archivo a mi FTP, para luego realizar una acción automática, de pronto me pueden ayduar con alguna idea???, ?Como saber si subieron un archivo a mi FTP?

    • Peter Olle 5 años

      No les des acceso FTP. Crea un repositorio Git y en el puedes darle seguimiento exacto de todo lo que sucede.

      Saludos.

  10. Gamaliel 5 años

    Tengo ese problema y no he movido nada en el config porqué no me admite mis datos ni manualmente. Estoy usando Parallels.

  11. Gamaliel 5 años

    Error: Se ha producido un error en la conexión con el servidor. Por favor, verifica que la configuración es correcta.

    Poniendo exactamente los mismos datos que pongo para entrar al server

  12. Juan A. 4 años

    Mil gracias!!!

  13. Wendy 4 años

    No me funciona para instalar pluggins, con la versión nueva, estoy utilizando MAC, será que hay que incluir otro código?

    • Autor
      Peter Olle 4 años

      No tiene nada que ver con que usas tu, todo es a nivel servidor.

      Saludos.

      • wendy 4 años

        Entonces, vos sabés que debo hacer para que me actualice o me instale pluggins sin que falle?

        • Autor
          Peter Olle 4 años

          Justo como dice la noticia. Obvio tienes que poner correctamente la URL de tu FTP, usuario y contraseña, si están mal te va a fallar.

          Saludos.

Contesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

Contacto

Si necesitas contactar para cualquier cosa, por favor envía tu mensaje a continuación.

Enviando
Copyright © 2017 Noticias Wordpress en Español. Todos los derechos reservados.

Inicia Sesión con tu Usuario y Contraseña

¿Olvidó sus datos?